Partial Service Outage

Incident Report for FastTrack360-EU

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 14:12 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 01, 2025 - 13:41 BST

Investigating

We are currently investigating a service outage affecting some customers where users are unable to access the FastTrack360 environment. Our technical team are working on this as the high priority. We appreciate the significance of this issue and will provide updates as they come to hand.
Posted Jul 01, 2025 - 13:30 BST
This incident affected: Services (Advertise - Posting, Application Processing, Timesheet Interpretation, Email, SMS, Cloud Storage, API, MarketPlace, Bullhorn-FastTrack Integration).